idea报错“Static methods in interface require -target:jvm-1.8”

idea报错“Static methods in interface require -target:jvm-1.8”

如题,在 idea 中跑 java 、scala 混编代码时,出现上面的错误。问题的原因很明显是 idea 中的 jdk 版本设置有问题,针对性作如下排查:检查项目的 java 版本在File-> Project Settings中,检查检查idea的 java 版本在File-> Se...

IDEA报错Target level '1.6' is incompatible with source level '1.7'

解决IDEA 编译级别 Error:java: Target level '1.6' is incompatible with source level '1.7'. A target level '1.7' or better is required 打开之后发现有一个编译级别设置的不对 更改如下...

本页面内关键词为智能算法引擎基于机器学习所生成,如有任何问题,可在页面下方点击"联系我们"与我们沟通。

社区圈子

开发与运维
开发与运维
集结各类场景实战经验,助你开发运维畅行无忧
6444+人已加入
加入
相关电子书
更多
蚂蚁金服高级开发工程师萧恺:IDEA 插件开发入门教程
立即下载