iOS SDK快速入门

SDK基于CocoaPods管理依赖包,您需要在电脑上安装CocoaPods。更多信息,请参见CocoaPods Guides。安装CocoaPods。sudo gem install cocoapods配置环境变量。export GEM_HOME=$HOME/.gem export PATH=$GEM_HOME/bin:$PATH编译源码。通过终端...

iOS SDK接入

使用 Cocoapods 安装 SDKCocoaPods 安装完成后,还需要在你的项目根目录创建一个Podfile文件,添加如下内容:#指定 Master 仓库和阿里云仓库 source 'https://github.com/CocoaPods/Specs.git' source '...

iOS端Demo集成

如果没有安装cocoapods,请先安装安装后在AlivcAIODemo目录下执行pod install。cd AlivcAIODemo#如果失败,请带上“-reop-update”参数 pod install 打开工程。open AlivcAIODemo.xcworkspace 配置License 申请试用License。申请成功后,...

mPaaS 10.1.68 升级指南

如您尚未安装 CocoaPods mPaaS插件,请您在终端执行以下脚本安装 CocoaPods 插件。sh<(curl-s http://mpaas-ios.oss-cn-hangzhou.aliyuncs.com/cocoapods/installmPaaSCocoaPodsPlugin.sh)如您已安装CocoaPods mPaaS 插件,则可以直接...

iOS开发

确保电脑已经正确安装Ruby环境(Mac电脑自带,需要确认下是否有安装)在Mac终端窗口中输入如下命令:sudo gem install cocoapods 创建新工程。选择file>new>project创建新工程。导入SDK。SDK 库名:AlicomRTCSDK.framework 下载...

mPaaS 10.1.60 升级指南

如您尚未安装 CocoaPods mPaaS插件,请您在终端执行以下脚本安装 CocoaPods 插件。sh<(curl-s http://mpaas-ios.oss-cn-hangzhou.aliyuncs.com/cocoapods/installmPaaSCocoaPodsPlugin.sh)如您已安装CocoaPods mPaaS 插件,则可以直接...

基于已有工程且使用 CocoaPods 接入

本文介绍如何基于 CocoaPods 原生的插件扩展机制生成各项配置,进而快速接入 mPaaS。前置条件已安装 CocoaPods 1.0.0 及以上版本,并确保要接入的工程是 CocoaPods 工程。已安装 Cocoapods-mPaaS 插件。如您尚未安装该插件,可使用以下命令...

iOS

安装CocoaPods。sudo gem install cocoapods 创建Podfile文件。进入项目所在路径,执行以下命令创建Podfile文件。pop init 编辑Podfile文件。platform:ios, '8.0' target 'AliRTCPodTest' do pod 'AliRTCSdk','1.17.44' end 说明 此处pod...

接入 SDK

本文介绍如何基于已有工程使用 CocoaPods 接入内容中台 SDK。添加 SDK安装 Cocoapods-mPaaS 插件。执行以下命令进行安装:sh (curl-s http://mpaas-ios.oss-cn-hangzhou.aliyuncs.com/cocoapods/installmPaaSCocoaPodsPlugin.sh)登录 ...

SDK集成

Pod集成:在终端窗口中输入以下命令,安装CocoaPods。重要 请提前在Mac中安装Ruby环境。sudo gem install cocoapods进入项目所在路径,在终端窗口中输入以下命令,创建Podfile文件。pod init编辑Podfile文件,添加直播SDK依赖。如需直播...

iOS端

前提条件 环境中已安装CocoaPods。SDK集成 使用pod方式添加阿里云播放器SDK和Native RTS SDK的依赖文件。打开终端窗口。进入项目所在路径,创建Podfile文件。pop init 编辑Podfile文件,添加最新版本的依赖。pod 'RtsSDK' pod '...

安装SharePoint 2016

本文介绍如何安装SharePoint 2016的具体步骤。前提条件 已注册阿里云账号。如还未注册,请先完成账号注册。已创建Windows Server 2012系统的ECS实例。背景信息 需要安装SharePoint 2016系统环境需要满足如下要求:基础配置:Windows Server...

ECS产品Windows无法卸载远程桌面服务

2012或2016系统安装了远程桌面服务,此服务需要授权,授权到期后,会限制远程登录,此时需要卸载远程桌面服务,& 但是手动无法正常卸载远程桌面服务。错误信息如下。解决方案 打开 注册表,找到以下两个注册表,右键选择 权限。HKEY_LOCAL_...

ECS搭建Microsoft SharePoint 2016

本教程介绍如何在阿里云ECS上搭建Microsoft SharePoint 2016。背景信息 Microsoft SharePoint是Microsoft SharePoint Portal Server的简称。SharePoint Portal Server是一个门户站点,使得企业能够开发出智能的门户站点,这个站点能够无缝...

使用开发小助手

使用 CocoaPods前置条件已安装cocoapods-mPaaS 插件。需保证 mPaaS 基线版本≥10.1.60。接入步骤使用 cocopods-mPaaS 的命令 可以生成如下 Podfile 文件,然后执行 pod install(或 pod update)。mPaaS Pods Begin plugin cocoapods-...

自助建站方式汇总

安装SharePoint 2016 安装SharePoint 2016 本教程主要介绍如何在Windows Server 2012操作系统的ECS实例上安装SharePoint 2016。部署并使用Docker Docker是一个开源的应用容器引擎,让开发者可以打包他们的应用以及依赖包到一个可移植的镜像...

Windows Server 2016自建安装IIS

本文介绍在ECS服务器 Windows Server 2016系统中如何安装IIS。重要 阿里云提醒您:如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,...

使用 CocoaPods 无法集成服务,错误信息:Unable to ...

问题详述使用 CocoaPods 无法集成服务,且错误信息为:Unable to find a specification for AlicloudFeedback 问题分析CocoaPods 使用不当。解决方法清除 CocoaPods 缓存,同时也清除仓库缓存,确保 CocoaPods 为最新版(经测试在1.2.1版本...

【虚拟补丁】某财务平台远程命令执行漏洞

升级IIS和Nginx低版本至IIS10.0和Windows 2016。本地安装用户需尽快确认备份文件是否完整,以及做了异地备份。云上客户请及时开启镜像功能。如果存在上述文件,表示已中毒,您需要进行如下修复。重系统,并更新畅捷通T+的最新产品补丁。...

获取代码示例

接入Cocoapods 接入移动框架移动框架代码示例 Cocoapods 和 Extension移动网关移动网关代码示例 Cocoapods 和 Extension消息推送消息推送代码示例 Cocoapods 和 Extension移动同步移动同步代码示例 Cocoapods 和 Extension移动分析移动分析...

HttpDns iOS:CocoaPods 集成常见问题及解决方案

仓库目录(默认为~/.cocoapods/repos);git clone https://github.com/aliyun/aliyun-specs.git ~/.cocoapods/repos/可执行 pod repo list 查看本地 Pod 仓库信息。pod repo add 或 git clone 失败?class="reference-link">pod repo add...

iOS SDK接入报错相关问题排查步骤

常见的内容:CocoaPods报错“Unable to find a specification for AlicloudFeedback”。和阿里百川其他包中的 UTDID发生冲突。用户反馈主界面提示“获取配置失败”。举例 1:CocoaPods 报错“Unable to find a specification for ...

iOS 冲突处理

http://mpaas-ios-test.oss-cn-hangzhou.aliyuncs.com/cocoapods/installmPaaSCocoaPodsPlugin.sh)安装完成后,使用命令 pod mpaas version-plugin 确认是 beta 版本。重新运行命令更新本地基线:pod mpaas update 10.1.68。使用 mPaaS_pod...

用户反馈是否可以用手动配置,不用自动...CocoaPods 集成...

问题详述用户反馈是否可以用手动配置,不用自动工具 CocoaPods 集成?问题解答两种方式都支持,具体的集成步骤详情可参考 SDK 文档。

如何解决Swift项目CocoaPods集成时Podfile文件中使用...

若Swift项目CocoaPods集成时Podfile文件中使用use_frameworks!关键字,建议单独将framework进行手动集成,具体步骤请参见iOS SDK接入的集成步骤章节。适用于 HTTPDNS

用户反馈利用CocoaPods报错

问题详述用户反馈利用CocoaPods报错:The‘Pods-card’target has frameworks with conflicting names:utmini.framework and utdid.framework.问题分析在手动集成时, utmini.framework还有utdid.framework冲突了。应该是集成前项目已经有...

iOS端Pods集成SDK常见问题及解决方案汇总

或手动拉取Pod仓库工程到CocoaPods仓库目录(默认为~/.cocoapods/repos);git clone https://github.com/aliyun/aliyun-specs.git ~/.cocoapods/repos/可执行 pod repo list 查看本地Pod仓库信息。pod repo add 或 git clone 失败?pod ...

接入方式介绍

接入若当前已有工程通过 Cocoapods 来管理 SDK 的依赖,推荐您使用 Cocoapods 接入,具体步骤参考 基于已有工程且使用 CocoaPods 接入。在 iOS,mPaaS 采用的是 Objective-C 开发语言。如果您的工程采用的是 Swift 开发语言,可以通过桥接...

阿里云SDK

本文档主要介绍各语言原版、升级版 SDK 的安装方式、使用教程等,帮助用户更方便快捷地使用阿里云产品的 OpenAPI。除此之外,我们还提供了 OpenAPI 开发者门户,欢迎开发者们体验,体验地址如下:

Alibaba Cloud Toolkit

Alibaba Cloud Toolkit(Eclipse插件,后文简称Cloud ...您在本地完成应用程序的开发、调试和测试后,可以使用在IDE(如Eclipse或IntelliJ)中安装的Cloud Toolkit插件,通过图形配置的方式连接到云端部署环境并将应用程序快速部署到云端。

接入 iOS

统一存储支持 基于 mPaaS 框架接入、基于已有工程且使用 mPaaS 插件接入 和 基于已有工程且使用 CocoaPods 接入 三种接入方式。根据不同的业务需求,可实现多种数据存储方案。包括:APDataCenter、KV 存储、DAO 存储、LRU 存储、自定义存储...

添加 SDK

CocoaPods 接入三种接入方式。您可以参考 接入方式介绍,根据实际业务情况选择合适的接入方式。前置条件您已接入工程到 mPaaS。更多信息,请参见以下内容:基于 mPaaS 框架接入基于已有工程且使用 mPaaS 插件接入基于已有工程且使用 ...

接入 iOS

CocoaPods 接入三种接入方式。您可以参考 接入方式介绍,根据实际业务情况选择合适的接入方式。前置条件您已经接入工程到 mPaaS。更多信息,请参见以下内容:基于 mPaaS 框架接入基于已有工程且使用 mPaaS 插件接入基于已有工程且使用 ...

添加 SDK

本文将引导您在基于 mPaaS 框架、基于原生框架且使用 mPaaS 插件或基于原生框架且使用 CocoaPods 的接入方式下,添加诊断或消息推送 SDK。说明 诊断功能支持上述三种接入方式,您可以自由选择。更多信息,请参见 接入方式介绍。诊断功能...

添加 SDK

插件接入以及基于已有工程且使用 CocoaPods 接入三种接入方式。您可以参考 接入方式介绍,根据实际业务情况选择合适的接入方式。前置条件您已接入工程到 mPaaS。更多信息,请参见以下内容:基于 mPaaS 框架接入基于已有工程且使用 mPaaS ...

添加 iOS SDK

框架、基于原生框架且使用 mPaaS 插件 以及 基于原生框架且使用 CocoaPods 这 3 种接入方式,您可以自由选择。前置条件您已经接入工程到 mPaaS。更多信息,请参见以下内容:基于 mPaaS 框架接入基于已有工程且使用 mPaaS 插件接入基于已有...

环境要求与配置

本章节中SDK 采用 cocoapods 管理依赖,建议采用 cocoapods 1.2.0 或以上版本。在xcode工程Podfile中添加以下行,集成SDK。source 'https://github.com/CocoaPods/Specs.git' source '...

多码识别

CocoaPods 接入三种接入方式。您可以参考 接入方式介绍,根据实际业务情况选择合适的接入方式。前置条件您已经根据您的接入方式,将扫一扫组件 SDK 添加至工程。更多信息,请参见以下内容:基于 mPaaS 框架接入基于已有工程且使用 mPaaS ...

添加 SDK

CocoaPods 接入三种接入方式。您可以参考 接入方式介绍,根据实际业务情况选择合适的接入方式。前置条件添加移动网关 SDK 前,确保已完成以下操作:接入工程到 mPaaS:基于 mPaaS 框架接入基于已有工程且使用 mPaaS 插件接入基于已有工程且...

混合云DevOps构建是否可以在自定义前置脚本中执行pod...

编辑配置中不使用cocoapods命令执行pod update,因为pod update命令会更新本地.cocoapods仓库,网络耗时较长。解决方案 可以在构建前置脚本emas_build_env_init.sh中执行pod update-no-repo-update或pod install no-repo-update等pod命令,...
共有200条 < 1 2 3 4 ... 200 >
跳转至: GO
新人特惠 爆款特惠 最新活动 免费试用